Administrateur

  • Profile picture of echeveste
  • Profile picture of Jean-Louis Giavitto
  • Profile picture of Philippe Cuvillier
  • Profile picture of arshiacont

Antescofo

Groupe Public active 3 days et 3 hours ago

The user group for Antescofo.

Including Antescofo in Max standalone applications

Auteur 3 Utilisateurs souscrits |
Profile photo of jkapusci
jkapusci

Hello all,
As I am trying to create a standalone Max 7 Application with Antescofo but encountering problems.
Antescofo in the built application shows strange behavior when reading scores. It receives a “read my-file.asco.txt” command but
instead of loading the requested file it tries to load a different one and comes back with an error message:
unable to include file ‘/Volume/(here some randomly generated garbage)’ No such file or directory
Antescofo~ – Abort loading score file ‘/Volumes/……..

The file that I call on in my read command has a completely different name and is not part of any ‘/Volume/’ folder.
Strangely, sending to Antescofo the same “read my-file.asco.txt” string seems to result in a request for a different
garbage file name within the mysterious /Volumes/ folder.
My score files were included in the standalone and just in case the Application
sits in the same folder as the scores.

If I click on ‘read’ and use a pop-up dialog to manually choose the score file the loading works fine.

The ‘read’ string works perfectly well when the patch is open with Max 7 (not as standalone).

What am I doing wrong?
Thanks,
Jarek

Décembre 31, 2015 à 03:43 #16591
Profile photo of arshiacont
arshiacont

Hi Jarek and sorry for the late reply.

Antescofo uses Max’s (or PD’s) built-in path features. Basically, everytime you call a score file without a full path, it will try to find the path in Max/Pd’s defined path resources. Note that this is not Antescofo BUT Max/Pd themselves doing that.

The last time I build an Antescofo Standalone, I did not have any problem. Maybe you are using a very old patch and somewhere before your “score” command you are “cleaning up” the paths? If that’s the case, just remove those “cleanings”.

If your scores are “fixed” I recommend just including the files next to the APP file and just calling score file names with the score/read commands. Another option would be to try to include them inside the Application Bundle.

I will do a test myself this afternoon using a simple patch to see if I can replicate this.

Arshia

Janvier 4, 2016 à 07:23 #16622
Profile photo of jkapusci
jkapusci

Dear Arshia,
Thank you for the reply. I am afraid I tried all of the things you suggested. I am not cleaning the paths, I have placed the app in the same folder as the scores that I am trying to load, I have included the scores folder in the bundle, and the scores are within the paths that Max knows about. Still, when I send Antescofo a read command with one of those score names it comes with the error of attempting to load some garbage-named file within a mystery “Volumes” folder. The patch finds movie files and sound files without a problem. It is only the scores-to-Antescofo connection that does not seem to work. I wonder if you were able to reproduce the issue and if you have any additional suggestions. Thanks,
Jarek

Janvier 4, 2016 à 09:06 #16623
Profile photo of Kai Yves Linden
kyl

The “garbage”-style path string might also be caused by non-ASCII characters in the path, especially characters with diacritics. The Mac OS X file system (HFS Plus) uses combining characters for letters with diacritic marks like accent aigu, umlaut, caron etc. which may confuse applications which are not completely aware of how such characters are represented and to be compared in the Unicode system. This might or might not be a determinant of the above problem but I nevertheless recommend to avoid such letters in the names of files and folders.

Janvier 4, 2016 à 09:25 #16624
Profile photo of jkapusci
jkapusci

I am afraid this is not the problem either. Please see attached image of the file names I am trying to load… (I tried skipping the .asco within their names but it made no difference)
Thanks!

Attachments:
  1. Scores

    Scores.png

Janvier 4, 2016 à 09:36 #16625
Profile photo of arshiacont
arshiacont

Jarek,

Download the following ZIP file for a test on your machine:
http://echanges.ircam.fr/filez/download.php?ad=61913WhqZs

It contains a very simple Antescofo patch with only a “read toto.txt” and the corresponding txt file next to it. It has the same patch as Standalone. It works fine here!

It was generated by Max 7. The patch which is used to generate the standalone is also there.

Let us know if it works fine on your machine. If it doesn’t, then it’s related to your machine… .

ALSO: Check your Max Version! I see that in 7.0.6 they have fixed a path normalization problem! If it’s older, then I recommend upgrading.

Janvier 4, 2016 à 09:50 #16628
Profile photo of jkapusci
jkapusci

Dear Arshia,
Thanks for helping out. I run Max 7.1.0.

I tried your patch and it worked fine on my computer too.

I decided to replace your file-name with mine and create a standalone without including the folder,
just putting the .app next to the file. It worked!
I did then again the “right thing” – I created a standalone and included in the script the scores folder
and the problem was back!
So the conclusion is when you build the standalone don’t include the scores as a folder, just place the .app next to them.
Thanks again!
Jarek

Janvier 5, 2016 à 08:28 #16647
Profile photo of arshiacont
arshiacont

Just an update on this issue:

If you build a Standalone Application out of Antescofo and include an Antescofo score file in the APP bundle (as you would want to do in certain cases), the regular READ/SCORE procedure will probably fail. We are discussing this issue with Cycling’74 developers as it seems like there is a potential problem in accessing such files using a path (as you’d normally want to do) since the file itself actually won’t exist as a regular file!

Until this problem is fixed, an alternative would be to NOT include the file in the App Building process, but to put to right next to the generated .app file.

Thanks to @jourdan for helping us and bringing the issue to Cycling74 developers! We will keep you posted on the progress.

For geeks: When you build a Standalone Application and include a file in the building process, the file doesn’t physically exist in the App Bundle as a regular file but it is integrated inside the generated .mxf file. There is therefore no real ‘file’ per se to load since Antescofo uses its own parser. It however works with other objects such as the Text object. This means that we should find a solution in terms for this very special case.

Janvier 5, 2016 à 20:04 #16660
Profile photo of arshiacont
arshiacont

This is now corrected in Antescofo 0.91 which was just released!

You can now safely include Antescofo scores in the build process of your Max patch Standalone (true also for scores using @insert for including external definitions).

BTW: We recommend everyone to upgrade to this version of Antescofo as it solves many behavior bugs that we encountered during the Antescofo Mini-Symposium Meetings in November and beyond.

Janvier 8, 2016 à 18:01 #16690

Vous devez être connecté pour répondre à ce sujet.

Log in now