Administrateur

  • Profile picture of echeveste
  • Profile picture of Jean-Louis Giavitto
  • Profile picture of Philippe Cuvillier
  • Profile picture of arshiacont

Antescofo

Groupe Public active 1 day et 21 hours ago

The user group for Antescofo.

Opening Ascograph

Auteur 3 Utilisateurs souscrits |
Profile photo of halg
halg

Hi,
i’ve downloaded the new version of Antescofo, that seems to work correctly with my MAx 6.1.9 patch.
But i can’t open anymore Ascograph…
The Max window :
antescofo~: AscoGraph is ON with remote host: localhost, remote port: 6789, port receive 5678 .
open -a “/Applications/Max 6.1/packages/ircam-antescofo/externals/Ascograph.app/Contents/MacOS/Ascograph” –args –score “/Users/henrialgadafe/Documents/Sons/Max libraries/patch henri/Les ames errantes/lesameserrantesII.txt” -x 14 -y 60 -W 1397 -H 947 –showtoppanel

In the attachment the report problem.

Thanks for all

Henri

PS : iMac OSX 10.8.5

Novembre 2, 2015 à 10:37 #15747
Profile photo of Grig Burloiu
Grig Burloiu

Hello Henri,
Do you get the same error if you FIRST open AscoGraph and THEN load your score file into antescofo/ascograph?

  • Cette réponse a été modifiée 2 years ago par Profile photo of Grig Burloiu Grig Burloiu.
Novembre 2, 2015 à 12:01 #15757
Profile photo of halg
halg

Hi Grig,
yes, same problem…

Novembre 2, 2015 à 12:12 #15761
Profile photo of Grig Burloiu
Grig Burloiu

We’re trying to replicate the crash…
So, Ascograph opens fine and then crashes on loading the score? Does it happen with any score file, or just this one? If it’s just this one, maybe you can upload it so we can try it out.

Novembre 5, 2015 à 10:09 #15814
Profile photo of halg
halg

Hi Grig,

Not exactly…. I’ve tried to open it by all the ways.
1- Clicking directly on it, with max open or close.
2- With Max, creating a new patch with Antescofo, then loading different scores.
Every times the window “report problem for ascograph” appears.

The following lines don’t have much sense for me, i presume you notice them in the report:
Dyld Error Message:
Symbol not found: __ZNSt12out_of_rangeD1Ev
Referenced from: /Applications/Max 6.1/*/Ascograph.app/Contents/MacOS/Ascograph
Expected in: /usr/lib/libstdc++.6.dylib
in /Applications/Max 6.1/*/Ascograph.app/Contents/MacOS/Ascograph

Thanks

Henri

Novembre 5, 2015 à 11:15 #15815
Profile photo of Pierre
Pierre

It looks like a compilation problem of Ascograph to me:
after demangling __ZNSt12out_of_rangeD1Ev, the missing symbol is _std::out_of_range::~out_of_range() so maybe Ascograph is somewhat using exceptions while support for exceptions is not compiled in. If this exception is raised, it also means from a code point of view that there is an allowed access to a vector or some container like that.

Novembre 5, 2015 à 14:18 #15818

Vous devez être connecté pour répondre à ce sujet.

Log in now