Administrateur

  • Profile picture of picasso
  • Profile picture of Axel Roebel

AudioSculpt

Groupe Public active 1 week et 1 day ago

User Group for AudioSculpt, AudioSculpt Lite and Analysis/Synthesis Command-line Tool users.

Spectrum becomes black by analyzing file with long duration or rich spectrum

Auteur 2 Utilisateurs souscrits |
Profile photo of MariaRose
MariaRose

Hello, ASculptors,

Does anybody know about the problem (and how to solve it)..
When I analyze file with long duration or rich spectrum and I scroll in Spectrum-window then it gets black..I must close AS and open it new again and analyze it again.
Im using Mac 10.11.6 with 1,6 GHz Intel Core i5; 8 GB 1600 MHz DDR3; Intel HD Graphics 6000 1536 MB.
Maybe its problem with Graphic Card?

Thanks a lot

Octobre 8, 2017 à 17:56 #24024
picasso
picasso

Hi,

You may have exceeded the available memory. Not particularly the one needed for the analysis, but the one needed then to render it, especially if
you can see the sonogram overview, but the screen then goes black once you zoom in.

Please, can you tell how long is your file, and what are your analysis parameters ? (window size, window step, oversampling (in FFT Size))
You can find those analysis parameters under AudioSculpt Menu > Analysis > Sonogram Analysis.

Best regards,
Charles

Octobre 9, 2017 à 07:51 #24025
Profile photo of MariaRose
MariaRose

Hi Charles

Thanks a lot for your response. So i think its memory problem.. I tested it with file wich has duration of 10.05min
First with 4800samples and I got error message. Then I tried with 2200 samples and it works.. (you can see other settings in screenshots I uploaded)

and by the way.. maybe you can tell me what is fundamental frequency? :) .. it is still not clear for me.

Thanks a lot
All the best

Lena

Attachments:
  1. error-message

    error-message.png

  2. error-message

    error-message.png

  3. analyze-2

    analyze-2.png

  4. analyze-2

    analyze-2.png

  5. analyse-1

    analyse-1.png

  6. analyse-1

    analyse-1.png

Octobre 10, 2017 à 12:56 #24029
picasso
picasso

Hi MariaRose,

This duration should not be a problem at all… it is even small.

Your oversampling value is your problem here, it is far too high and that is why you reach the sonogram limit very quickly.

Unless you have a very special reason to use such a great FFT oversampling value (here you set it to x8), i would suggest you to keep it to the default (x1).

This way, you should be able to increase the window size, and window step without reaching the memory limit for the sonogram.

Best regards,
Charles

Octobre 10, 2017 à 13:44 #24037
Profile photo of MariaRose
MariaRose

Ok,

Thank you very much for your help!

Octobre 10, 2017 à 15:58 #24039

Vous devez être connecté pour répondre à ce sujet.

Log in now