Administrateur

  • Profile picture of Robert P.

Modalys

Groupe Public active 3 weeks et 4 days ago

Modalys physical modeling sound synthesis user group

error playing sound

Auteur 2 Utilisateurs souscrits |
Profile photo of sdistefano
sdistefano

Bonjour,

j’ai quelques souci pour démarrer , je viens d’installer 3.4.7 sur OS 10.8.5

Modalisp s’ouvre bien mais lors de l’éval du premier code ( issus du tutorial) le son donne erreur ( image ci joint)

Idem avec d’autres exemples.

Savez vous d’ou ça peut venir ? (J’ai vu qu’il n’y a pas un accès preferences dans le menu pour chercher qqs réglages…)

MERCII !

bye
Salvo

Mars 17, 2018 à 18:48 #25925
lochard
lochard

Bonjour,

Votre image n’apparait pas. Pouvez essayer avec un fichier .zip ?

Il nous sera plus facile de vous aider… Merci !

Jean Lochard

Mars 20, 2018 à 15:35 #25943
Profile photo of sdistefano
sdistefano

Bonsoir Jean,
J’ai rajouté l’image del’erreur sur Modalys( en jpeg et zip ). en effet en lisant les exemples Lisp inclus dan le dossier exemples de l’application, l’esecution “Run” donne toujours ce type d’erreur.
Merci de m’avoir proposé votre aide !
Salvo

Modalisp 3.4.4 sur MacOS 10.8.5

Mars 20, 2018 à 20:38 #25946
lochard
lochard

Bonjour,

J’ai recopié votre script. Il fonctionne bien sur ma machine même si il est préférable de créer un autre accès pour le point d’écoute pour éviter d’écouter l’insrument à lendroit où on applique la force comme suit :

;;;-*-Mode: Lisp; Package: MODALYS -*-

(new)
(setf my-string (make-object ‘mono-string))
(setf my-string-access1 (make-access my-string .5 ‘trans0))
(setf my-string-access2 (make-access my-string .8 ‘trans0))
(make-connection ‘force my-string-access1 (const 1))
(make-point-output my-string-access2)
(run 2)
(play)

Avez-vous essayé avec la dernière version de Modalys ?

Jean

Mars 21, 2018 à 10:00 #25949
Profile photo of sdistefano
sdistefano

Merci Jean

j’ai installé 3.5.0 l’installation a fonctionné en pratique (dossier créé à la racine du dossier Applications) , même si un message d’erreur s’est affiché à la fin de l’installation.

Infine le problème de l’erreur de lecture venait de la configuration audio , j’avais sélectionné 2 perif différentes en IN et OUT ayant de plus des freq échantillonnage différentes.
Maintenant j’ai choisi IN OUT Integrée et la meme freq d’echantillonage et ça marche.`
Pour information même la 3.4.4 marche, c’est bien le réglage audio qu’il faut “soigner”.

IL y a qqs jour un message pour un pb d’installation Orchids, pouvez vous me donner un contact ? je n’ai pas de réponse, impossible de télécharger SOL.

Merci bien !

Salvatore

Mars 21, 2018 à 19:04 #25959
lochard
lochard

Bonjour,

Oui, je voulais aussi vous dire de vérifier la configuration audio du système, Modalys utilisant le matériel choisi dans les préférences son pour jouer les sons.
N’hésiter pas à poster des questions sur la liste si vous rencontrez des problèmes avec Modalys.

Jean

Mars 23, 2018 à 09:47 #25981

Vous devez être connecté pour répondre à ce sujet.

Log in now