Spat 4.7.7

Spat v4.7.7 is now available.
Please note that Max 5 is no longer supported and that Mac OS 10.7 (or higher) is required.

Windows version now supports 32 and 64 bit versions of Max.

****************************************************************
Release Version :   4.7.7
Release Date    :   04/2015

* OSX >= 10.7 is now required; Max 5 support is deprecated
* spat.viewer : added ‘gridcolor’ attribute
* spat.viewer : added ‘dashedgrid’ attribute
* spat.viewer : fix bug with vu-meters
* spat.eigenencode~ : fix several bugs
* spat.distance : fix possible crash
* spat.oscroute : added ‘set’ message
* spat.frequencyresponse : added ‘getphase’ and ‘getmagnitude’ messages
* spat.matrixctrl : major gui optimization; added scrollbars
* spat.cascade~ : added ‘crossfadetime’ attribute
* spat.viewer : fix minor bug with speakers positions when multi-view is enabled
* spat.viewer.embedded : fix bug with background color
* spat.spat~ : deprecated ‘directsoundrerouting’ attribute (will be replaced in future versions)
* Windows : added 64 build
* Windows : added SIMD optimizations (major CPU improvement)
* spat.spat~ : fixed bug with spread message (it was applied to all sources indifferently)
* spat.rat : added ‘maxfreq’ attribute (upper frequency for the analysis)
* updated ‘audiofileextract’ : can now extract an arbitrary list of channels
* added spat.osc2spat
* fixed critical bug in filter crossfades. affecting spat.hlshelf~, spat.spat~, and many others
* fix severe bug with spat.oper (source presence/distance messages not output in the right order)
* spat.pan~ : fix major bug with @subwoofer panning type

spat-compatibility

 

 

Leave a Reply

You must be logged in to post a comment.