Group Admins

  • Profile picture of picasso
  • Profile picture of Axel Roebel

AudioSculpt

Public Group active 1 week, 4 days ago

User Group for AudioSculpt, AudioSculpt Lite and Analysis/Synthesis Command-line Tool users.

PM2 Warning: don't recognize -filepat Kernel returned error -1

Author 4 Subscribed Users |
Profile photo of MUS3
MUS3

Dear,

I’m analyzing a wav file (mono, 16bit) of orchestral performance captured from the audience, close to the stage.

I chose to apply markers manually to each section of the part.

Then I generated a sonogram so I could get a CHORD-SEQ result to extract an SDIF file from the recording.

However, the moment I click “Do analysis”, the following message appears: “the kernel pm2 reported an error“:

PM2 Warning: don’t recognize -filepat
Kernel <pm2> returned error -1

pm2 -t -S”/Volumes/Dados/Thiago/Dropbox/Doutorado_UFPB_2013_2017/Tese/Sinfonia em Quadrinhos/HP – SQ – audio/Hermeto.Pascoal.-.Sinfonia.em.Quadrinhos.MONO.XXX.wav” -filepat XXX=2016 -Aseqs -B0.000000 -E1340.217163 -N8192 -M2229 -I278.625000000000000 -Wblackman -OS -p1 –mode=0 -q40 -m55.000000000000000 –chords=”/Applications/AudioSculpt 3.4.0/Temp/chords” -B0.000000 -E1340.217163 “/Applications/AudioSculpt 3.4.0/ChordSeqs/tempChord-0054.cs.sdif”

Would any of you know how to resolve this situation?

Thanks for the help.

November 30, 2016 at 18:07 #19986
Profile photo of Karim
Karim

Hi,

Are you running this on Sierra (OS) ? If it is the case, well there is your problem. New apple security policy is preventing pm2 to run. THe dev team are aware of this and will try to fix this issue ASAP.

Best
K

November 30, 2016 at 19:04 #19987
picasso
picasso

HI MUS3,

I think this is probably a problem due to the parsing of the filename, and AudioSculpt find possibly
a tag used to activate the filepat option.

1-Try to remove or replace all ‘[‘ and ‘]’ with another character.
2-Or simply rename the file using a simple name (to test)

And retry :)
Tell me how it goes then.

HTH

Best,
Charles

November 30, 2016 at 19:26 #19988
Axel Roebel
Axel Roebel

I am afraid on Sierra that this is not the problem. The message is not the one that was reported as the kernel is started but does create the error message with filepat.

In fact the filepat thing is meant to support split audiofiles that are stored as a pair of files named according to name.L.wav name.R.wav, we use
the name name.XXX.wav -filepat XXX=L,R in supervp to process these two files synchronously. Pm2 however does not support these split files (yet)
and so that’s where the error comes from.

Now as the command line is containing

-S”/Volumes/Dados/…..MONO.XXX.wav” -filepat XXX=2016

The file appears to be MONO and is probably named with XXX by MUS3 – so it could be that due to some misguided automatism triggered by the XXX in the name AS expects this file to be a split multi channel file and invents the pattern 2016 out of the blue. If I am guessing correctly here MUS3 should be able to solve the problem by means of renaming the file avoiding the XXX in the name.

If this is the case then we should probably have a more robust means to trigger the file-pattern mechanism.

If really this is a split audio file then for sinusoidal analysis the file needs to be converted to interleaved format prior to running the analysis.

Best
Axel

November 30, 2016 at 19:30 #19989
Axel Roebel
Axel Roebel

In fact my reply was to Karim and not to Charles who wrote just a few seconds before me :-)
Axel

November 30, 2016 at 19:34 #19990
picasso
picasso

Yes Axel,

It is a bug in the way it is triggered/detected in AudioSculpt and it should be strengthen.

Best,
Charles

November 30, 2016 at 19:49 #19991
Profile photo of Karim
Karim

Sorry guys,
my bad
k

November 30, 2016 at 19:50 #19992
picasso
picasso

Well, actually it is more my bad than yours Karim 😉

November 30, 2016 at 20:01 #19993
Profile photo of MUS3
MUS3

Dear friends,

As mentioned, the problem was solved by changing the file name.

Thanks for the help and suggestion of all.

Best,
Thiago Cabral (Member of the research group “MUS3″ from Brazil).

December 1, 2016 at 17:04 #20022

You must be logged in to reply to this topic.

Log in now