Group Admins

  • Profile picture of picasso
  • Profile picture of Axel Roebel


Public Group active 3 hours, 32 minutes ago

User Group for AudioSculpt, AudioSculpt Lite and Analysis/Synthesis Command-line Tool users.

SDIF Library

Author 3 Subscribed Users |
Profile photo of António Florença
António Florença

Hello everyone,

I’ve tried to build the SDIF Library from sources. I’ve downloaded the zip file of the latest version from SourceForge, I unzipped it into my home folder (/Users/antonioflorenca) and entered the following set of instructions in Terminal:

mv SDIF-3.11.4-src SDIF-3.11.4
cd SDIF-3.11.4
./configure –prefix=pwd –enable-shared=no –enable-pthreads=no
make install

Everything goes ok (with a few warnings), as far as I can see, until “make install” (I’ve also tried “sudo make install”), for which I get:

Making install in sdif
test -z “/Users/antonioflorenca/SDIF-3.11.4/lib” || .././install-sh -c -d “/Users/antonioflorenca/SDIF-3.11.4/lib”
/bin/sh ../libtool –mode=install /usr/bin/install -c ‘’ ‘/Users/antonioflorenca/SDIF-3.11.4/lib/’
libtool: install: /usr/bin/install -c .libs/libsdif.lai /Users/antonioflorenca/SDIF-3.11.4/lib/
libtool: install: /usr/bin/install -c .libs/libsdif.a /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
libtool: install: chmod 644 /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
libtool: install: ranlib /Users/antonioflorenca/SDIF-3.11.4/lib/libsdif.a
make[2]: Nothing to be done for `install-data-am’.
Making install in include
make[2]: Nothing to be done for `install-exec-am’.
test -z “/Users/antonioflorenca/SDIF-3.11.4/include” || .././install-sh -c -d “/Users/antonioflorenca/SDIF-3.11.4/include”
/usr/bin/install -c -m 644 ‘sdif.h’ ‘/Users/antonioflorenca/SDIF-3.11.4/include/sdif.h’
install: sdif.h and /Users/antonioflorenca/SDIF-3.11.4/include/sdif.h are the same file
/usr/bin/install -c -m 644 ‘sdif_version.h’ ‘/Users/antonioflorenca/SDIF-3.11.4/include/sdif_version.h’
install: sdif_version.h and /Users/antonioflorenca/SDIF-3.11.4/include/sdif_version.h are the same file
make[2]: *** [install-sdifincHEADERS] Error 64
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

Any idea what went wrong here and how I can fix it, if at all? Any help on this would be greatly appreciated.
I’ve attached a rtf file with all the output from Terminal running the instruction-set listed above.

All the best,

March 7, 2019 at 10:25 #29909
Profile photo of Frederic Cornu
Frederic Cornu

Hello António,
The issue is that you’re trying to install in the current directory, which does not work.
On the one hand, it’s usually better to install the package somewhere else, as it yields a simpler and cleaner install. On the other hand, if you just want to build the library there and maybe pick the parts you need, you should just run “make” and not “make install”. The executables will be in the “tools” directory, the headers in “include”, SdifTypes.STYP in “data”, and sdif.pc in the root directory. The only trick is the library (libsdif.a and is in the “sdif/.libs” directory, which is hidden and won’t appear in the finder

March 7, 2019 at 11:23 #29931
Axel Roebel
Axel Roebel


in case you want to create the python packages for using SDIF in python, you cannot do this with the SDIF library,
you ned to use EASDIF, also the zip file in the SDIF repo is very old, you should not use it. We do maintain the repos and source code, but we don’t do any
releases any more.


March 7, 2019 at 11:38 #29936

You must be logged in to reply to this topic.

Log in now