Group Admins

  • Profile picture of davephillips

Linux Users Group

Public Group active 1 week, 4 days ago

For discussion of any and all points regarding the use of IRCAM software with the Linux operating system.

Startup Error on 64bit Debian

Author 2 Subscribed Users |
Profile photo of peterp
peterp

Having installed https://forge.ircam.fr/p/OM/downloads/get/OM_6.13.deb via dpkg -i after having satisfied missing dependencies via
sudo aptitude install gtk2-engines-murrine libcanberra-gtk-module desktop-file-utils

Trying to start OM up I do get to the dialog asking me where to start a new workspace. Upon having done so I get a dialog window with the error message
ERROR: Illegal instruction(4) [code 0] at 7F176B42A770
Unknown foreign code in module “/usr/share/openmusic/resources/lib/linux/OMAudioLib.so” [ #x7F176B325000 ]
rax 7F176B774A00 ; rbx 7F17741760A8 ; rcx 7F17740008D0 ; rdx 7F176B9DF190
rsp 7F1782574AA8 ; rbp 7F17741760B0 ; rdi 7F17741760C8 ; rsi 7F17740008D8
r8 7F176B358E60 ; r9 7F176B358E60 ; r10 E57 ; r11 7F176ADADE30
r12 7F17741760C8 ; r13 7F177C000B20 ; r14 4000049839 ; r15 40D0FF8FBC

In the console I started openmusic from there is further info posted:
“Loading PortMIDI library: libportmidi.so”
“Loading SDIF library: /usr/share/openmusic/resources/lib/linux/libsdif.so”
#P”libsndfile.so”
#P”libsamplerate.so”
“Loading Juce Audio library: /usr/share/openmusic/resources/lib/linux/OMAudioLib.so”
; Loading text file /home/peter/.local/share/OpenMusic/6.13/OMPrefs.lisp

“ERROR: Illegal instruction(4) [code 0] at 7F176B42A770
Unknown foreign code in module \”/usr/share/openmusic/resources/lib/linux/OMAudioLib.so\” [ #x7F176B325000 ]
rax 7F176B774A00 ; rbx 7F17741760A8 ; rcx 7F17740008D0 ; rdx 7F176B9DF190
rsp 7F1782574AA8 ; rbp 7F17741760B0 ; rdi 7F17741760C8 ; rsi 7F17740008D8
r8 7F176B358E60 ; r9 7F176B358E60 ; r10 E57 ; r11 7F176ADADE30
r12 7F17741760C8 ; r13 7F177C000B20 ; r14 4000049839 ; r15 40D0FF8FBC

Call to om-lisp::om-error-handler
Call to invoke-debugger
Call to error
Call to (subfunction system::|%FOREIGN-CALLABLE/lisp_signal_error_on_c_stack| (fli:define-foreign-callable \”lisp_signal_error_on_c_stack\”))
Call to juce::|%cffi-foreign-function/OPENAUDIOMANAGER|
Call to (method player-open ((eql :om-audio)))
Call to init-om-session
Interpreted call to common-lisp-user::init-om
Call to delivery::maybe-ryb-top-level
Call to mp::process-sg-function

OM then hangs without a GUI being created, and I have to force quit it with Ctl-C on the console.

What am I doing wrong? What could I try next?

June 5, 2018 at 21:43 #26721
Profile photo of anders
anders

Hi peterp. There’s probably an incompatibility between an old libc in your machine and the one expected by the distributed version of OMAudioLib.so.

You can compile the needed lib on your own cpu:

git clone git://git.forge.ircam.fr/omaudiolib.git
cd omaudiolib/Builds

then replace the Makefile you’ll find there with the one attached below, and run ‘make’

copy the resulting lib from ./build/OMAudioLib.so to /usr/share/openmusic/resources/lib/linux/OMAudioLib.so

Hope this solves your problem.

-anders

  • This reply was modified 6 months, 1 week ago by Profile photo of anders anders.
June 5, 2018 at 22:56 #26722

You must be logged in to reply to this topic.

Log in now