Group Admins

  • Profile picture of Robert P.

Modalys

Public Group active 2 hours, 57 minutes ago

Modalys physical modeling sound synthesis user group

.mlys script in Max 6 vs. 7

Author 2 Subscribed Users |
Profile photo of pabloland
pbloland

Hi all,
I have been working in Max, reading an .mlys script into modalys~, and everything works. However I am stuck with Max 6. It’s a rather processor intensive script, though Max 6 can handle it with minimal glitches. Max 7, however, stutters constantly and is basically unusable.

Before I post any examples I thought I’d see if this was familiar to anyone?

Current OS: OS X 10.10.5 (I’m about to upgrade, figured it was a good time to explore this issue)
Modalys: 3.4.4.rc2
Max: 6.1.10 vs. 7.3.5

Thanks,
Per

August 21, 2018 at 17:07 #27462
lochard
lochard

Hi Per,

Hmmm, can you post an example please ? I can do tests at home on El Captitan 10.11 and tell you what happens!

Cheers,

Jean

August 21, 2018 at 17:23 #27463
lochard
lochard

Hi Per,

Hmmm, can you post an example please ? I can do tests at home on El Capitan (10.11) and tell you what happens!

Cheers,

Jean

August 21, 2018 at 17:24 #27464
Profile photo of pabloland
pbloland

Hi Jean,

Absolutely. I just upgraded my system to Sierra (10.12), just to see if it made a difference. It doesn’t.
I also simplified the Max patch as much as possible – I didn’t think it would help the system, but should make it easier for you.

The zip I attached has both the Modalisp file used to generate the Mlys file, and the Mlys file itself. Simply opening the Max patch should load it automatically, and work. The difference between Max 6 and 7, on my end, is profound. I’m curious to see if you find the same.

Thanks for looking!
Per

August 23, 2018 at 04:13 #27483
lochard
lochard

Hi Per!

I just try your patch in Max 7 on High Sierra on my Ircam Macbook Pro computer (2.5 GHz Intel Core i7).

I had glitches at 48kHz and I/O/vector size set to 256. It’s much better with 512 for both parameters.

I was looking at your modalisp script : do you realy need the felt connection in the two dimensions ? I know that this one could be very cpu intensive…

Cheers,

Jean

August 23, 2018 at 09:18 #27505
Profile photo of pabloland
pbloland

Hi Jean,

Thanks for taking a look! I wish it were that simple for me, but unfortunately no. I had experimented with the I/O+vector size. As they go up the stuttering becomes less rapid, but it is still unusable. I also deleted two of the felt connections (you’re correct, I don’t need them for this version), but that didn’t seem to help either…

It sounds to me like you are able to use this patch in Max 7 when the settings are correct. Any ideas what could be bogging down my system? I have 16 GB ram and a 2.2 GHz Intel Core i7, so a bit slower than yours. But it sounds perfectly fine in Max 6. I’m stumped!

Thanks again,
Per

August 24, 2018 at 05:21 #27515

You must be logged in to reply to this topic.

Log in now