Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 20 hours, 58 minutes ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

Copy-paste in chord-seqs

Author 2 Subscribed Users |
Profile photo of michalszostalo
michalszostalo

Hi, I was wondering if there is a trick for copy-pasting withinin chord-seqs. I realize that it’s not really what you would call algorithmic composition, but this is probably my biggest frustration in OM.

The reason I ask is because for a few days after installing 6.13, copy-paste actually worked, but then it mysteriously disappeared again. The workaround is to drag something to a new chord-seq and then drag it back into the old one, but at that point it’s quicker to move the whole project to a MIDI sequencer. Any advice would be greatly appreciated.

May 1, 2018 at 21:03 #26452
Profile photo of Jean
Jean

Hi — I’m not sure there’s such thing as a feature that can mysteriously appear/disappear from one day to another :) but I do beleive copy/paste does not work very well in OM editors !

Can you be more specific about what do work and what doesn’t ? copy/paste within the same chord-seq editor ? From one to another ? etc. (detailed info can be useful)

A known bug is that copied chords actually paste but at the wrong place in the editor (usually very far ahead in time — zoom out at the mawximum to see if you don’t have chords by the very end of teh sequence)
=> I think I have fixed that recently and will publish a new release including the fix soon.

Best,
Jean

May 3, 2018 at 08:23 #26466
Profile photo of michalszostalo
michalszostalo

Thanks for your reply. I was also quite puzzled by the disappearing feature! Going between one editor and another is no problem, alt-click and drag seems to work just fine. The puzzling thing was within one chord-seq, I tried ctrl-c => ctrl-v and it really worked, a few times. The placement was actually TOO accurate – it would go exactly where I put the arrow, and then I had to quantize it to the grid. But then it stopped working, and nothing I tried made it work again. Even better would be if I could just alt-click and drag within a chord-seq, but as far as I know that’s never worked. If you do come up with a fix, I look forward to trying it out as, for now, I do process-oriented work in OM, then move to a 12-note midi sequencer for the more “creative” parts. Sometimes I have to go back and forth five or six times, and the microtones issue gets pretty confusing.

Best wishes,
Michal

May 3, 2018 at 18:37 #26468

You must be logged in to reply to this topic.

Log in now