Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 3 hours, 56 minutes ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

Exporting music XML file from Open Music to Finale

Author 2 Subscribed Users |
Profile photo of jamespricec
jamespricec

Hello, when I export a music XML file from Open Music to Finale all the 64th notes appear as quarter notes. However, when I export a Finale file to Open Music there is no problem. So is this an Open Music glitch? does anyone know how to solve this issue?

October 14, 2016 at 04:54 #19319
Profile photo of Karim
Karim

Please check out this topic :

http://forumnet.ircam.fr/user-groups/openmusic/forum/topic/musicxml-from-poly-missing-notes/

October 14, 2016 at 10:27 #19320
Profile photo of jamespricec
jamespricec

Hello KARIM, I tried the code but it didn’t work. The 64th notes will appear as quarter notes in Finale when exported from OM. Am I doing something wrong?

Attachments:
  1. POLY-64th-NOTES-APPEAR-AS-QUARTER-NOTES.

    POLY-64th-NOTES-APPEAR-AS-QUARTER-NOTES..jpg

  2. POLY-64th-NOTES-APPEAR-AS-QUARTER-NOTES.

    POLY-64th-NOTES-APPEAR-AS-QUARTER-NOTES..jpg

  1. poly-2.xml
  2. poly-2.xml
October 15, 2016 at 18:25 #19330
Profile photo of Karim
Karim

Dear James,

Can you send me the patch (or the voice instance)?
I will try it out.
And by the way can you specify your configuration
Finale version, Om version, OS version etc…
It could be that it is still not working….
(hope not though…)

BEst
K

October 15, 2016 at 19:16 #19336
Profile photo of Karim
Karim

OK … wait a minute…
THe xml file looks like the file didn’t load…!
Put the export-mxml-new-vers18opt.lisp file in your patches folder (you will find it in the OM folder),
Then launch OM.
After that DON”T use the export feature from the poly’s menu, but use the export-musicxml function from the fonction menu.
There you will have the change.
And please be advised, this is a temporary fix. It will be included in Om ASAP.

BEst
K

October 15, 2016 at 19:21 #19337
Profile photo of jamespricec
jamespricec

Hello Karim,

I tried putting the export-mxml-new-vers18opt.lisp file in the patches folder and then using export-musicxml function from the fonction menu but it didn´t work. When I export a music XML file from Open Music to Finale (2012) all the 64th notes appear as quarter notes. Is there another way to fix this problem?

December 16, 2016 at 04:21 #20218
Profile photo of Karim
Karim

Dear James,

This means that the patch didn’t load. Maybe because you forgot to re-launch OM after putting the patch ?

Best
K

December 16, 2016 at 11:39 #20221
Profile photo of jamespricec
jamespricec

Hello Karim,

Yes I re-launch OM after putting the patch. I am also getting an error message when selecting page presentation in the POLY menu. I´ve attached screenshots of the error message and the 64th notes as quarter notes or as 4096th notes.

Thank you for your help.

James

  • This reply was modified 11 months, 1 week ago by Profile photo of jamespricec jamespricec.
Attachments:
  1. ERROR

    ERROR.jpg

  2. ERROR

    ERROR.jpg

  3. example-2

    example-2.jpg

  4. example-2

    example-2.jpg

  5. example

    example.jpg

  6. example

    example.jpg

December 16, 2016 at 16:08 #20223
Profile photo of Karim
Karim

Dear James,

Can you just send me the poly (or voice) in order to check this out and even better join the xml also in order to see what’s wrong here. I am afraid that it might be an OM version 6.10 issue.
I will check this against my own version and will report back.
Best
K

December 16, 2016 at 17:06 #20237
Profile photo of jamespricec
jamespricec

Karim,

I’ve attached both POLY and XML files.

Thank you for your help.

James.

December 16, 2016 at 17:55 #20239
Profile photo of Karim
Karim

Thanx James for the files.

As I have suspected, the problem you are having is either, with the om 6.10 version, or most probably due to the fact that you are using a windows version, isn’t it ? And if it is the case, i believe, sending you a patch will not be of a good help since on windows Lispworks, the patches , (I think… not sure hmm ), are not effective unfortunately. — We will need a little help from our friends (Jean, … ?)… Anyhow, with the patch , and with your poly, i have a correct xml file that i attach. (I am using om6.9.x on debian linux)

Best
K

December 17, 2016 at 01:00 #20248
Profile photo of jamespricec
jamespricec

Hello Karim,

Thank´s for the files. Yes I am using Windows. So, is there anything that can be done to solve this issue on a Windows version?

James.

December 17, 2016 at 17:40 #20258

You must be logged in to reply to this topic.

Log in now