Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 1 day, 13 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

Microtones playback in tutorial 10

Author 5 Subscribed Users |
Profile photo of Trond LOSSIUS
Trond LOSSIUS

Hi,

I’m reading an old pdf of tutorials (more or less same content as here: http://recherche.ircam.fr/equipes/repmus/OpenMusic/user-doc/DocFiles/Tutorial/tut010/Index.html) and trying out the tutorial patches. Tutorial 10 seems to suggest that one has to set up microtuning with pitch bend messages in order to hear the effect of it. However, in the tutorial patch, even if I set pitch bend for all four channels to 0 (midi pitch bend value 8192), the quartertone chord-seq still plays back in the QT synth with quarter-tone intonation.

I’ve tried routing the midi messages to max and monitor, and it seems to me that pitch bends are set automatically whenever chord-seq starts playback, thus overriding any setting that I might have done previously myself by evaluating pitchwheel objects.

If this is correct and expected behaviour (it does make a lot of sense), I’d suggest updating the tutorials to reflect it, provided that they are still being maintained.

Cheers,
Trond

February 1, 2015 at 15:10 #12607
Profile photo of Karim
Karim

Hi Trond,

Indeed, these Tutorial are not up2date.
However, it seems that there’s a little confusion here.
First of all, we use the pitch-wheel function in OM not the pitch-bend. And as I am looking at one of these,
someone has made a change in them. (Yes i am the author of these tutorials). Someone slipped in som new funcitons.
I beleive this is due to the new midi systeme of OM 6.9.
Are you talking about this version ?
And the one who slipped in the mc-to-pitchwheel stuff didn’t specify this. I am sorry.
So to be back to this particular tutorial, all what pitch-wheel does , is to send a pitchbend msg to the midi port assigned to.
So maybe you didn’t send the zeros pitchbend messages through the pitch-wheel om function to the correct port ???
If you do , it should re-initialize the pitchbend and all is supposed to be good.
However, since they changed a lot of stuff in midi, it could be that there is another midi bug concerning this.

Best
K

February 1, 2015 at 16:55 #12610
Profile photo of Karim
Karim

… just tried the tut 10 in om 6.9 thru midishare, and everything is ok. (i am using the pitchbend range = 2 which is the standard).
So it could be that you are using the other midi system on another plateform ????
K

February 1, 2015 at 16:58 #12612
Profile photo of Trond LOSSIUS
Trond LOSSIUS

Thanks for your answer, Karim.

As far as I understand the MIDI specification, the midi pitch wheel of a MIDI controller sends the Channel Voice Pitch Bend Change message (see e.g. http://www.midi.org/techspecs/midimessages.php). Using OM with midishare, and routing MIDI to the IAC bus, and then monitoring this bus in Max with the midiin and xbendin objects, I indeed see messages arriving whenever I evaluate one of the pitchwheel objects in the OM tutorial 10. Here’s a simple Max patch to demo this:

— Pasted Max Patch, click to expand. —

However, regardless of which of the pitchwheel objects in tutorial 10 that I evaluate, whenever I play the chord-seq object in the lower left corner of the OM patch, I see pitch bend messages arriving in Max, not just note-on messages. Before any notes are played, pitch bend messages sets up quarter-tone tuning, and at the end of the playback session, they are set back to no detuning. Here’s what I get printed in the Max window:

bend: 8192 1
bend: 9216 2
bend: 10240 3
bend: 11264 4
noteon: 60 100 1
noteon: 60 0 1
noteon: 60 100 2
noteon: 60 0 2
noteon: 60 100 3
noteon: 60 0 3
noteon: 60 100 4
noteon: 60 0 4
noteon: 61 100 1
noteon: 61 0 1
noteon: 61 100 2
noteon: 61 0 2
noteon: 61 100 3
noteon: 61 0 3
noteon: 61 100 4
noteon: 61 0 4
noteon: 62 100 1
noteon: 62 0 1
bend: 8192 1
bend: 8192 2
bend: 8192 3
bend: 8192 4
bend: 8192 1
bend: 8192 2
bend: 8192 3
bend: 8192 4

So, to me it seems like the pitch bending is now taken care of automatically. IMHO that’s nice!

February 1, 2015 at 17:13 #12614
Profile photo of Karim
Karim

Thanx Trond,

I don’t know if this is good .
What i know, that in OM (and even far more than this), the detuning concerns channels.
So as it is stated in the tutorial, the channels are parsed according to what the objet’s channel is.
Finale adopted a pitchbend tuning per note. And this is real lousy since if you happen to play fast notes, you will have
hgorrible portamentos. I don’t know if the latest version of OM does this. If it does, i think this is a real lousy thing.
I will test and tell you.
By the way i don’t now how the midi protocol in om has changed. Since no one informed us users.
I hope it is not the case.

Best
K

February 1, 2015 at 18:03 #12615
Profile photo of Trond LOSSIUS
Trond LOSSIUS

Hi Karim,

OM is not doing it the Finale way, which I agree would be awful. It is still assigning various microtunings to separate channels. The only difference as compared to earlier versions seems to be that we no longer need to manually set up the appropriate detunings ourselves using pitchwheel. chord-seq now seems to be automatically taking care of this.

Best,
Trond

February 1, 2015 at 19:13 #12616
Profile photo of Jean
Jean

Hi Trond,

As you noticed the OM online tutorial pages are pretty much officially outdated.
However the tutorial patches that you can import in your workspace (menu “Help/Import tutorials/OM tutorials”) should be OK.

Indeed we decided to homogenize the pitchweel message to the official MIDI spec (as in http://www.midi.org/techspecs/midimessages.php) => the overall range (coded on 14 bits) is 0-16383, and 8192 means no pitchwheel.
The mc-to-pitchwheel should now help to deal with this without caring about the MIDI spec.

About the bend messages you received in the Max window, they are indeed sent automatically at playing a chord-seq when it is set to quarter or eighth tones, and when the “Auto microtone bend” option is selected in the OM/MIDI preferences.
You can therefore disable this behaviour by unchecking the option.

Best
Jean

February 1, 2015 at 22:06 #12617
Profile photo of sialsound
sialsound

Hi
I’ve just returned to OM and updated from 6.11 to 6.12 trying to solve an issue with exporting MIDI files with quarter tones to Reaper.

Previously this working well (mid 2016). The exported MIDI files appeared with channels 1-4 in the Reaper MIDI editor, and the data appeared in the “Pitch” drop down menu too. The files then be configured to play 1/4 tone samples in SamplOMatic

However now the 4 channels are exporting but not the actual pitch wheel data – it is blank and seems to be lost in the export from OM.

Just wondering if anyone else has had this issue or knows of a solution
bests
Lawrence

May 15, 2017 at 02:33 #22366
Profile photo of anders
anders

empty

  • This reply was modified 1 month, 1 week ago by Profile photo of anders anders.
May 16, 2017 at 14:38 #22386
Profile photo of anders
anders

Hi Lawrence. Various approaches for ‘dwim’ features for microtuning related stuff are not 100% settled it seems. Until the dust settles I think you’ll get what you ask for using the attached patch file. It saves pitchbend messages in the .midi files, which will tune the first four channels to accommodate 1/8-tone resolution.

You can either use #’save-as-midi and supply a non-nil value for the keyword :retune-channels, or Context-click->Export->MIDI if the relevant editor is set to something else than the default semi-tone approx.

Adjust the values and channel numbers in #’setup-retune-messages if you need some other values here for now. We’ll see in what shape this ends up in the sources later.

-anders

May 16, 2017 at 14:41 #22389
Profile photo of sialsound
sialsound

Hi Anders,
thanks for the patch – all working now.

Much appreciated

regards
Lawrence

May 29, 2017 at 00:15 #22454

You must be logged in to reply to this topic.

Log in now