Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 1 day, 20 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

MIDI Playback MacOS

Author 2 Subscribed Users |
Profile photo of Steve97
Steve97

Hi everyone,

I usually use OpenMusic on my Windows Laptop however installed it on my mac yesterday (macOS Sierra 10.12.6).

My only issue is that I can’t get any objects to playback, eg notes and chords; when I go to MIDI Preferences there are no MIDI playback devices found, and it just says ‘disconnected’, with no option for me to assign a device to a port.

Is this an issue with my MAC not having the right MIDI drivers or something that I can fix in fix in OpenMusic? Sorry if this has already been asked!
Kind Regards,

Steve

January 8, 2019 at 11:34 #28750
Profile photo of Jean
Jean

Hi Steve,

OM for Mac does not come with an in-built MIDI synthesizer.
You must connect the MIDI output ports to some external software or synth.
The easiest way to connect MIDI ports is using the Mac IAC drivers (activate them from your computer’s general MIDI Settings — see how).
I ususally recommend SimpleSynth to start with and test MIDI outputs: it is pretty straightforward to get to work. Then you can use more advanced tools and software.
I think the instructions on this page are still up-to-date:
http://repmus.ircam.fr/openmusic/midi

Best,
—Jean

January 8, 2019 at 12:16 #28751
Profile photo of Steve97
Steve97

Thanks Jean! This worked perfectly.
Many Thanks,

Steve

January 9, 2019 at 14:16 #28758

You must be logged in to reply to this topic.

Log in now