Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 1 day, 13 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM 6.12 on Windows – Great, but DPI/fontsize issues

Author 2 Subscribed Users |
Profile photo of fa101
fa101

Hello folks,

I’m having some problems with OM on Windows 10 concerning the size of the fonts!
I do hope you can help, or consider this issue for the next release.

Neither unscaled, or scaled is providing to be a particularly workable solution for me.
(I’m on a 14′ laptop at standard 1920×1080 HD resolution, not a fancy 4k monitor).

Problem 1.

With HighDPI scaling turned off for OM, OM is super tiny. No surprise.

Yet some very strange things happen when a number of objects
are drawn! For example, chord-seq has very strange note-heads, and when opened, the bottom of chord-seq window
is overwritten by the menu selection boxes.

However, what is surprising is that the screen ‘real-estate’ looks mostly ok – ie, NOT super tiny – you
can get plenty of objects on the screen, and for the most part, unlike the fonts, they are readable (at least
to me, and my eyes are not the best). That’s in unscaled mode. It’s small, and perhaps a little too small,
but not that bad at this resolution. Yet the fonts are not working (see screenshots).

Problem 2.

With HighDPI scaling turned on, whilst everything is in proportion as it should be, fonts are super fuzzy (no surprise) –
but they are really not good at all to read – but more problematically, the size of the patch windows is disproportionally large (in my view).
Most patch elements appear to be disproportionately magnified and the screen size is not really made use of.

Any chance someone could look at the scaling of the various elements in Windows?

How about this for a solution – at least a temporary one, as I understand this can be a complex issue –

– Is there any way please we could user-specify the font and font size *for the workspace text* (not within patches or the listener,
but in the workspace) list of patches? If only this
was user-adjustable, then OM could be made to look mostly ok by running in ‘don’t scale’ and making the text bigger.

Just being able to correctly see the workspace list of patches would be an awesome step forwards.

OM itself runs very well on Windows 10. It’s fast, loads quickly, and works very well with my mac patches
with no issues. Great job.

Thanks very much for your assistance –

Ambrose

Attachments

1. typical text render with default scaling enabled
2. When DPI scaling is off, the fonts look like this! (Just being able to adjust them would make a difference)
3. With DPI scaling off, the noteheads look like this! (Note though, how the patch is an appropriate size despite
some

Attachments:
  1. om-scaling-off-noteheads

    om-scaling-off-noteheads.png

  2. om-with-scaling-enabled

    om-with-scaling-enabled.png

May 3, 2017 at 17:16 #22258
Profile photo of fa101
fa101

Sorry, here is what the fonts in the workspace look like in un-scaled mode.

Attachments:
  1. win10-problem-fonts-in-list-view

    win10-problem-fonts-in-list-view.png

  2. win10-problem-fonts-in-list-view

    win10-problem-fonts-in-list-view.png

May 3, 2017 at 17:28 #22263
Profile photo of Jean
Jean

Hi Ambrose,

I’m using a pretty recent Laptop with a 1920×1080 screen resolution and can not reproduce any of this unfortunately.
I don’t think I have this HighDPI option available though…

Jean

May 5, 2017 at 13:50 #22269
Profile photo of fa101
fa101

Hello Jean

I think i’ve identified the problem.

If your display manufacturer recommends font scaling beyond 125% then neither the workspace, or the patch windows
draw the fonts correctly. The font appears to be bigger than the space allowed for it somehow. If you set your font scaling to 125% or 100%, then everything works ok and there is no problem.

This is fine, but I have terrible eyesight! I really need the default 150% display scale my screen recommends at least!
Meanwhile, I guess anyone on a really high-res screen, like a 4k display, will need to have the font scaling set at 150% or 200%.

I hope this is of some use to you. It’s just the workspace window, and patch windows in which this happens. The lisp listener
is ok.

Thanks so much for all your work Jean,

Best

Ambrose

Attachments:
  1. Capture

    Capture.png

  2. Capture

    Capture.png

May 8, 2017 at 12:21 #22320
Profile photo of Jean
Jean

on my laptop, 150% scaling gives kind of blurry rendering for some fonts but I can’t reproduce the same behaviour either.
I’m not sure what can be done about it anyway, since this is not a parameter that I can easily access from OM..

May 15, 2017 at 23:59 #22372
Profile photo of fa101
fa101

Hi Jean

I think this issue is fixed in Lispworks 7.0 – one of the advances from version 6 is High-DPI support for windows.

Hope that helps!

Ambrose

June 8, 2017 at 21:26 #22536

You must be logged in to reply to this topic.

Log in now