Group Admins

  • Profile picture of Karim
  • Profile picture of Jean


Public Group active 1 day, 4 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM 6.13 builds for Linux (rpm, deb)

Author 3 Subscribed Users |
Profile photo of anders

Hi all.

Linux packages (.rpm, .deb) of the latest OM release 6.13 are available


November 30, 2017 at 20:55 #24519
Profile photo of rc


Got problems installing OM 6.13 in Ubuntustudio (Ubuntu 16.04.4 LTS). I installed OM_6.13.deb but got the following message once I tried to create a workspace:

ERROR: Illegal instruction(4) [code 0] at 7F3E8C495770
Unknown foreign code in module “/usr/share/openmusic/resources/lib/linux/” [ #x7F3E8C390000 ]
rax 7F3E8C7DFA00 ; rbx 7F3EA017C468 ; rcx 7F3EA0000020 ; rdx 7F3E8CA4A190
rsp 7F3EAF0CFB08 ; rbp 7F3EA017C470 ; rdi 7F3EA017C488 ; rsi 7F3EA0000028
r8 7F3E8C3C3E60 ; r9 7F3E8C3C3E60 ; r10 E0E ; r11 7F3E83D0BE60
r12 7F3EA017C488 ; r13 7F3EA80008C0 ; r14 4000049839 ; r15 40D0FF8FBC

the same happened with OM_6.13.tar.bz2

I tried also to build following the instructions on

but got in terminal:
make: *** No rule to make target ‘../../Source/OMAudioBuffer.cpp’, needed by ‘build/intermediate/Release/OMAudioBuffer_106ae79.o’. Stop.

so I think that I’m missing something. Any help will be appreciated.

Thanks & regards,

June 22, 2018 at 03:12 #26825
Profile photo of anders

Hi rc, yes seems you’ll have to build OMAudioLib yourself. The compile error you get seems to be caused by using an old leftover Makefile in the sources. I have updated the omaudiolib submodule at the repo now, so hopefully the build should work. Please try this and report back:

git clone git://
cd OM
git submodule init && git submodule update –remote
cd omaudiolib/Builds/Linux/

and replace the existing coming with your OM (supposedly /usr/share/openmusic/resources/lib/linux/ with the new one in build/


  • This reply was modified 7 months ago by Profile photo of anders anders.
June 22, 2018 at 10:48 #26829
Profile photo of rc

Hi Anders,

Thanks, it works!
I was missing libcurl, but installing libcurl4-openssl-dev I was able to build it.

best regards,

June 25, 2018 at 21:57 #26861
Profile photo of CJ Miller

I am trying this, but the instructions are not working here. The build fails with the error of:

make: *** No rule to make target ‘../../Source/OMAudioBuffer.cpp’, needed by ‘build/intermediate/Release/OMAudioBuffer_106ae79.o’. Stop.

Any suggestions?

August 14, 2018 at 05:40 #27439
Profile photo of anders


Sorry, the steps outlined above were incomplete, you’ll need to update the omaudiolib submodule to the current origin/master branch. So in the list above, use

git submodule update –remote

ie, with the added “–remote” (updated in the answer above now).

I’ll see if i find a way to have this behavior as default in the submodule config.


  • This reply was modified 7 months ago by Profile photo of anders anders.
August 14, 2018 at 09:03 #27440

You must be logged in to reply to this topic.

Log in now