Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 6 hours, 19 minutes ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM clouds – encapsulation problem

Author 2 Subscribed Users |
Profile photo of fa101
fa101

Does anyone know how to fix this problem.

Take any OM clouds patch (see example below, from the tutorials)
Encapsulate the patch
It then doesn’t work at all, with an error about the arguments:
“Got one arg, wanted at least 2….”

What am I doing wrong? All the solvers appear to have this problem.
Om6.11 and 6.12 (haven’t checked previous to this).

Thanks

Ambrose

Attachments:
  1. Screen-Shot-2017-07-21-at-15.51.08

    Screen-Shot-2017-07-21-at-15.51.08.png

  2. Screen-Shot-2017-07-21-at-15.51.08

    Screen-Shot-2017-07-21-at-15.51.08.png

  3. Screen-Shot-2017-07-21-at-15.50.52

    Screen-Shot-2017-07-21-at-15.50.52.png

  4. Screen-Shot-2017-07-21-at-15.50.52

    Screen-Shot-2017-07-21-at-15.50.52.png

July 21, 2017 at 15:57 #23155
Profile photo of Jean
Jean

Hi Ambrose,
I can see that too. There’s apparently a problem in the way OMCloud processed are ‘compiled’ in order to be encapsulated in other patches.
The code looks pretty tricky :) so this bug will probably require a little bit of work to figure out and fix…
Jean

July 26, 2017 at 10:26 #23196
Profile photo of fa101
fa101

Please don’t worry on my account Jean, you’ve probably got much better
things to do than sort this one out.

I’m trying to find solutions to constraints problems in bulk, which require
me to feed the domains to an encapsulated patch.

I’ve re-made my patch with pmc and omcs, and I think it’s working ok.

best,
Ambrose

July 27, 2017 at 16:55 #23242

You must be logged in to reply to this topic.

Log in now