With the new Ircam Forum website coming, the user groups will be migrated towards a new platform.
Please plan user groups downtime between Monday, March 25th and Tuesday, March 26th.

Group Admins

  • Profile picture of Karim
  • Profile picture of Jean


Public Group active 1 day, 9 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM installer for Linux?

Author 4 Subscribed Users |
Profile photo of rc


Where can I download the latest OM installer for Linux?
I tried:
(ask me for login and after I couldn’t find it)
(the .rpm throws and error with software installer)

Best regards,

September 13, 2018 at 11:51 #27788
Profile photo of anders

Hi RC. Seems the openmusic downloads page at forge.ircam.fr is broken atm. I’ll check what’s happened.

The rpm should work fine however, just checked it again here. If you want help to debug or failseek something on your own machine you will need to provide some more info, such as OS, version etc.

September 13, 2018 at 12:04 #27789
Profile photo of Jean

Sorry, the access to the download page on forge.ircam.fr was disabled.
I think it’s ok now.

September 13, 2018 at 13:17 #27790
Profile photo of rc

Thanks for the quick reply, Anders!
I tried the rpm in Ubuntu 18.04.1, got a “Sorry, something went wrong” in the software application.

September 13, 2018 at 13:20 #27791
Profile photo of anders

Right. No the .rpm will probably not be useful on Ubuntu or other Debian based OS’es.

The access to https://forge.ircam.fr/p/OM/downloads/ should be opened again now, where you’ll find a .deb package. Have fun!

September 13, 2018 at 13:58 #27793
Profile photo of rc

Got it. Thanks Jean and Anders!
The only thing is that I still have an OMAudioLib error on startup (maybe it would be great to have the build instructions in some readme file)

ERROR: Illegal instruction(4) [code 0] at 7FE2E2537AA0
Unknown foreign code in module “/usr/share/openmusic/resources/lib/linux/OMAudioLib.so” [ #x7FE2E2431000 ]
rax 7FE2E2870A20 ; rbx 7FE3001898A8 ; rcx 7FE3000008D0 ; rdx 7FE2E2ADFE38
rsp 7FE30E1B1AA8 ; rbp 7FE3001898B0 ; rdi 7FE3001898C8 ; rsi 7FE3000008D8
r8 7FE2E246DD80 ; r9 7FE2E246DD80 ; r10 2F ; r11 7FE2E1EB7530
r12 7FE3001898C8 ; r13 7FE308000B20 ; r14 4000049839 ; r15 40D100796C

September 13, 2018 at 14:14 #27794
Profile photo of rc

Regarding building omaudiolib, I can’t clone it.
The following link is not working:

Best regards,

September 13, 2018 at 14:30 #27798
Profile photo of Jean

sorry, I’ve been messing up accesses. I’m progressively moving projects out of the forge.ircam.fr server towards better source management systems.
You can now find the omaudiolib repository here: https://github.com/openmusic-project/omaudiolib.git

September 13, 2018 at 14:34 #27799
Profile photo of fdsdb

Hi All.

If useful, I have resolved some OM audio initial problems in the following way. I must premise that I have just updated my Linux workstation to Fedora 28 distro. I have installed OM last version by the rpm file on ircam forge site, but I had problems on audio, similar to above mentioned ones. So I have donwloaded the omaudiolib project from Jean’s above address and compiled on my system: only digitized ‘make’ in terminal in the right directory and installed missing libraries requested for compilation. They were reported in error messages during first compilation attempts. Finally I have make a backup of the /usr/share/openmusic/resources/lib/linux/OMAudiolib.so (to be sure…) and then copied the new compiled OMAudiolib.so inside /usr/share/openmusic/resources/lib/linux. Of course with root privilegies.
I have not deeply tested everything, but it seems to run. On Ubuntu it should be the same procedures, maybe some directory could be different, I am not very acquainted with Ubuntu.



September 13, 2018 at 15:55 #27800

You must be logged in to reply to this topic.

Log in now