Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 3 days, 5 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM Score Player Setup on Linux

Author 3 Subscribed Users |
Profile photo of nagymusic
nagymusic

Hello!
I wonder if anyone could advise on how to setup the default score player on Linux with OM 6.13. I was able to successfully set it up on Windows and Mac, but every time I attempt to configure the portMIDI setup on the Linux machine, OM application crashes.

Thank you!

June 1, 2018 at 21:31 #26661
Profile photo of anders
anders

Hi nagymusic. If it crashes it’s a bug somewhere, and nothing you’re doing wrong.

To be able to help, and hopefully fix the bug, perhaps you could be a bit more precise as the exactly when it crashes, and if there are any messages please pass them on. Also any messages occuring during startup.

What does your MIDI preferences window show just before it crashes (attach a screenshot please)?

Which exact version of OM are you running?

Which linux-dist (and version) are you running?

Thanks.

-anders

June 2, 2018 at 00:07 #26663
Profile photo of nagymusic
nagymusic

Thanks, Anders. Below you will find more information about my issue.

I started using Linux fairly recently. I currently use Elementary OS Loki built on Ubuntu 16.04.3 LTS (Linux 4.13.0, GTK+ 3.18.9); the device is a PC laptop, Quad-Core Intel, i5-8250U CPU @ 1.60GHz. The Linux distro has been working fine, but if you have a suggestion for a more robust distro, so to speak, don’t hesitate to make a recommendation.

The OpenMusic version is 6.13. I’ve been using it on Linux for a while now, and it has never crashed until now when I needed to activate the playback. In the MIDI Preferences, the options for the Default Score Player are midi-player (currently selected), microplayer, and osc-scoreplayer. I attached the screenshot of what it looks like with those default settings. The PortMIDI Setup (see attached) Output Devices lists Midi Through Port-0, followed by TiMidity ports 0 though 3. It is when I select one of these Output Devices options and hit apply that the application crashes, and without any message that I can retrieve. However, I do always get an error message in the Listener when I attempt to play an OM object: PortMIDI ERROR: port 0 is not connected. Check MIDI preferences to connect MIDI devices ?

Thank you once again for your time to look into this!

Zvony

Attachments:
  1. Screenshot-from-2018-06-01-21.57.50

    Screenshot-from-2018-06-01-21.57.50.png

  2. Screenshot-from-2018-06-01-21.57.50

    Screenshot-from-2018-06-01-21.57.50.png

  3. Screenshot-from-2018-06-01-21.55.47

    Screenshot-from-2018-06-01-21.55.47.png

  4. Screenshot-from-2018-06-01-21.55.47

    Screenshot-from-2018-06-01-21.55.47.png

June 2, 2018 at 03:11 #26665
Profile photo of fdsdb
fdsdb

Hi,

If useful, I have tried this combination: started timidity on terminal with -iA option; set OM port on midi through; set through port on timidity ports by kaconnect. It runs. I enclose screenshot.
Otherwise I use Qsynth without problems, and in this case I can set qsynth input port directly from OM midi port setup.
I am on Fedora 20, 3.19.8-100.fc20.x86_64.

I hope this can help somehow.

fdsdb

  • This reply was modified 4 months, 2 weeks ago by Profile photo of fdsdb fdsdb.
Attachments:
  1. Schermata-da-2018-06-02-0917121

    Schermata-da-2018-06-02-0917121.png

  2. Schermata-da-2018-06-02-0917121

    Schermata-da-2018-06-02-0917121.png

  3. Schermata-da-2018-06-02-091712

    Schermata-da-2018-06-02-091712.png

  4. Schermata-da-2018-06-02-091712

    Schermata-da-2018-06-02-091712.png

June 2, 2018 at 08:21 #26670
Profile photo of nagymusic
nagymusic

Thanks, fdsdb. Just a quick note to provide an update. I tried implementing your suggestions (including Qsynth), but the app crashes at the point when the OM port on midi though is selected.

June 2, 2018 at 13:31 #26676
Profile photo of fdsdb
fdsdb

Hi Nagymusic,

I am not able to understand why it happens.
You can try to connect OM not to through port, but directly to Qsynth port. It is that one red circled in enclosed screenshot. Probably port numbers can differ in your computer.
If it does not run, sorry, I have no other ideas, apart to try to search into /home/YOURNAME/.local/share/OpenMusic/6.13 (or other version) if there is some log message (or in /var/log) or to delete OM preferences file and restart OM. Good luck…

fdsdb

Attachments:
  1. Schermata-da-2018-06-02-174544

    Schermata-da-2018-06-02-174544.png

  2. Schermata-da-2018-06-02-174544

    Schermata-da-2018-06-02-174544.png

June 2, 2018 at 16:59 #26677
Profile photo of anders
anders

Hi nagymusic.

Elementary OS Loki built on Ubuntu 16.04.3 LTS

There’s probably imcompatibilities between the portmidi lib in your distro and the one expected by OM.

Check with ‘apt-cache show libportmidi-dev’. If this shows something like version 184 or 200, that’s a potential bomb for any application requiring portmidi not installed through your standard package system. If it shows 217 things should be ok, and we’ll look for other causes to your problems.

if you have a suggestion for a more robust distro, so to speak, don’t hesitate to make a recommendation.

Stay away from LTS distros if you don’t need it (e.g. running specialized servers, single-app use etc). All applications in continued development, and not directly accessible through your LTS package repos (like OM), will expect recent, stable, releases of the main distros – Fedora, Ubuntu, Debian, whatever.

June 3, 2018 at 10:54 #26681
Profile photo of nagymusic
nagymusic

Thanks, Anders. I ran ‘apt-cache show liportmidi-dev’ and got version 200. Will try Fedora; do you recommend Gnome or KDE?

June 3, 2018 at 15:11 #26682
Profile photo of anders
anders

and got version 200

Wonder why they do this to people, v. 200 is from 2010. Anyway, it probably explains why OM dies in your case.

do you recommend Gnome or KDE?

Gnome is the default (and what i prefer myself). Don’t know about KDE, sorry.

June 3, 2018 at 20:17 #26683

You must be logged in to reply to this topic.

Log in now