Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 2 days, 9 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

sample rate problem in OM 6.12

Author 2 Subscribed Users |
Profile photo of MarcoBidin
MarcoBidin

Hello,

I just installed OM 6.12, created a workspace and tried to set the sr to 48.000.
It doesn’t allow me to do so, only 44.100 possible.
At the same time, a colleague near me did the same and it worked

OM 6.12 on Yosemite 10.10.5 (both of us)

Any ideas?
(Of course, I tried re-installing OM and creating a new workspace. Didn’t work.)

Thank you!
Marco

April 1, 2017 at 14:25 #22061
Profile photo of Jean
Jean

Hi Marco. Indeed only 44100 seems proposed when you first open the workspace; however, I think just pushing “Apply” should set your selected audio device’s possible samplerates as possible options.. did you try that ?
It shall also work after you once save your preference/workspace and restart it..

April 1, 2017 at 21:33 #22062
Profile photo of MarcoBidin
MarcoBidin

Hi Jean,

I created a new workspace and did as you suggested. Worked perfectly.

The other workspace has gone weird: no sr at all, no outputs. I attach a screenshot.
Nothing bad, since I got nothing inside it yet.
(Of course, I tried synthesising something with omchroma, was not possible since “synthesize cannot divide by 0″)

Anyways, the new workspace is working properly (including synthesising with omchroma)
I’ll keep you up to date in case something happens.

Thanks for your reply!
M

Attachments:
  1. om_612_srproblem

    om_612_srproblem.png

  2. om_612_srproblem

    om_612_srproblem.png

April 1, 2017 at 22:11 #22063
Profile photo of Jean
Jean

So if you do “Apply” on this other workspace nothing happens with the SR options ?

Can you attach your preferences.lisp ?

April 1, 2017 at 22:30 #22066
Profile photo of MarcoBidin
MarcoBidin

Exactly
It is not even 44.100, it disappeared and it sets the out channels to 0.

I attach the file.

April 2, 2017 at 20:48 #22077
Profile photo of Jean
Jean

Can you select an other audio device ?

You preference file seems corrupted : it says :audio-device “^C” (wrong character)
I think if you change the audio output (or maybe just reselect the Built-in Output) things might come back as normal… ?

April 2, 2017 at 22:00 #22080
Profile photo of MarcoBidin
MarcoBidin

Nope, doesn’t change.
Tried selecting the rme audio interface than back to built in, several times. No luck.

As said, this is not a problem since the workspace is empty; in case I had some patches, would it be possible to repair the preferences file? Or better export the patches in a new, clean workspace?

Thanks!
M

April 3, 2017 at 08:39 #22081
Profile photo of Jean
Jean

Did you try to delete/temporarily remove the preferences file and restart the workspace ?
This should be like creating a new one…

April 3, 2017 at 09:39 #22082
Profile photo of MarcoBidin
MarcoBidin

Thank you Jean, that worked!
M

April 3, 2017 at 17:27 #22100

You must be logged in to reply to this topic.

Log in now