Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 5 hours, 46 minutes ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

workspace loads but doesn't appear

Author 2 Subscribed Users |
steenhuisen
steenhuisen

Hi,
OM 6.13
OS 10.13.4 High Sierra

Workspace loads, but no windows open other than the Listener, so all is at a standstill.
Reinstalled OM, made new workspace, it worked once, then same error.
Any ideas? Haven’t had this issue before, can’t find it in the archives.

Thanks,
Paul

June 27, 2018 at 00:24 #26864
Profile photo of Jean
Jean

Hi Paul — are you working with multiple screens ?
My guess is that the workspace window might be here but just saved with a wrong position (out of the screen area).
If this is the case, deleting the file wsparams.lisp in the workspace folder might bring the window back.

June 27, 2018 at 08:15 #26865
steenhuisen
steenhuisen

Hi Jean,
Yes, I’m using multiple screens. That’s interesting – I’ll try it. If I don’t write back further, it means your solution worked.
Thank you,
Paul

June 27, 2018 at 18:33 #26871
steenhuisen
steenhuisen

Quick note – it worked, but I have to do it (delete the workspace parameters lisp file) each time I open OM – this seems to be a new feature since I’ve installed High Sierra.
Best, Paul

June 27, 2018 at 19:20 #26872
Profile photo of Jean
Jean

Can you look what’s in wsparams.lisp and share it here ?
Also, what is your screen configuration ?
Thanks,
Jean

June 28, 2018 at 07:16 #26887
steenhuisen
steenhuisen

wsparams.lisp = (in-package :om)(setf *ws-params* (list 1 (om-make-point 1761 358) (om-make-point 280 480)))

I’m using a 15″ MacBook Pro with an iMac as a second display (extended off the right edge of the laptop, i.e. not mirrored)

Paul

June 28, 2018 at 19:18 #26919
steenhuisen
steenhuisen

ps, if I mirror the second display, the workspace appears, though on the right side of the larger mirrored screen (beyond where it would be on the laptop display).

June 28, 2018 at 19:27 #26920
Profile photo of Jean
Jean

I think there’s something wrong with initializing a window out of the “standard” screen region.
I’ll try to fix this in the next release.
In the meantime, workaround:
– bring the workspace window to the front (CMD+SHIFT+W)
– close it (CMD+W)
– re-open it (CMD+SHIFT+W)

Jean

July 24, 2018 at 09:02 #27234
Profile photo of Jean
Jean

I think this is fixed in OM 6.14:
http://forumnet.ircam.fr/shop/fr/forumnet/43-openmusic.html
=> let me know if it works !

August 28, 2018 at 10:01 #27546

You must be logged in to reply to this topic.

Log in now