Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 3 days, 6 hours ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

XML import issues

Author 2 Subscribed Users |
Profile photo of fa101
fa101

Hello everyone,

I’ve made a quick test file to illustrate a problem I’m having with OM’s
MusicXML import.

When I import a piano system, it all ends up on one line of a poly.
I’d like a right hand and a left hand, as separate lines/voices in the poly.

I have exported from Finale 25 and MuseScore. OM has the same problem with both
programmes. In Finale, it doesn’t matter also if I downgrade the XML version to 1.0, 1.1 or 2.0. Same problem.
I’m in OM 6.11 on mac.

I’ve attached:-

– the original testfile screenshot
– the xml testfile from musescore
– a screenshot of what POLY does to it.
The behaviour is the same if I use the importmusicxml object.

I’d be extremely grateful for your help! Perhaps it is something I’m doing wrong.

Ambrose

  • This topic was modified 6 days, 10 hours ago by Profile photo of fa101 fa101.
Attachments:
  1. importing_into_poly

    importing_into_poly.png

  2. original_test_export

    original_test_export.png

  1. xml-testfile.xml
March 20, 2017 at 18:37 #21954
Profile photo of Karim
Karim

Dear Ambrose ,

This is because there is nothing such as a Piano staff in OM for the moment.
You need to split your piano voices in multiple staves, and then you will have a correct Poly.

Sorry.
K

March 20, 2017 at 19:27 #21968

You must be logged in to reply to this topic.

Log in now