Group Admins

  • Profile picture of bouchereau
  • Profile picture of daubresse
  • Profile picture of esling

Orchids

Public Group active 1 week, 1 day ago

Welcome to the Orchids user group.

This user group is devoted to the Orchids orchestration system and its users, but also on the topic of computer-aided orchestration and generic sound mixture optimization. In order to facilitate the exchange of bug reports, idea and collaborative thinking, we encourage any kind of report on errors, bad or good results, desired features, ideas, remarks and any other topic.

Please report any unsolved problem, ideas or even cool sounds to this group and we will be glad to discuss it. If you want to start using the software, please read the full documentation, which provides turnarounds to known issues: http://repmus.ircam.fr/_media/esling/orchids-documentation.pdf

http://forumnet.ircam.fr/user-groups/orchids/
http://forumnet.ircam.fr/product/orchids/

fails to start up

Author 4 Subscribed Users |
Profile photo of axolotl7
axolotl7

I wonder if some kind soul could help me get up and running, as the app fails to start up for me. I downloaded the latest release (0.9.1-b) on my new Mac Pro (10.9.5), and the disk image verified and mounted, so I dragged and dropped the app as indicated to install. When I launch Orchids0.9.1.app, only one window opens, the “Clue” window, and it’s broken (see attached screenshot). When I select “About Max” from the Orchids0.9.1 application menu, it’s also broken. I’ve included the Max window in my screenshot in the hope that it helps diagnose the problem. I realize that it’s a standalone app, but could it be the case that there’s a conflict with my Max installations? I’m running both 6.1.9 and 7.0.1. I’ve already tried re-downloading and reinstalling the app. Thanks in advance…

Attachments:
  1. af-orchids

    af-orchids.png

January 13, 2015 at 03:54 #12401
Profile photo of esling
esling

Dear Axolotl7,

It is indeed an extremely weird situation and it is even the first time I see this “Clue” window ! Normally, the Max install should not interfere at all with the app (as it is a standalone package …). But just to be sure, you might ask to Daniele Ghisi for his patch versions to ensure that it is an app problem rather than a Max one.

All the best,
Philippe

January 18, 2015 at 14:54 #12440
Profile photo of sydy
sydy

Hello,

I know I’m not the only one who posts a thread about Orchids failing to start. I’ve read all previous messages about this issus and tried the following procedures :
– I downloaded the newest release of the bach library
– I placed the bach library in the /Applications/max 6.1.10/packages folder instead of having it in the /Documents/max/packages
– I also update max runtime => this helped at least to have a crash report and made the application start (of course without showing the interface)

I’m using max 6.1.10

I attached the crash report to this post and hope someone can help me with my problem.

Thank you very much in advance.

August 4, 2015 at 19:20 #14433
Profile photo of esling
esling

Dear Sydy,

Sorry to hear about your problem … but it is indeed an extremely strange one, seems that in your case it is the “Max Runtime” that is responsible for the crash, so I am quite unsure how we can bypass that …

So do you have a Max installed on your machine ? In that case, it might be that the app is being run on the runtime of your local install rather than being self-contained. In that case you might try the patch version that I just placed publicly here:
https://forge.ircam.fr/p/Orchids/downloads/

Another way to look more closely to the origin is to launch the Search from the console (in a Terminal) :
cd /Applications/Orchids0.9.1.app/Contents/Database/ && ./Search
Then run the application and look what messages pop out in the console.
(This will also work with the patch version)

All the best,
Philippe

August 8, 2015 at 16:57 #14448
Profile photo of HUSEAC
HUSEAC

I have the same crash problem on 10.10 and guess that it is related to diverging versions of the Max Runtime.
Trying to use the open patches from forge.ircam fails as well as two objects are missing: sy.route and dada.stage.
(I downloaded the sy package directly from Danieles site.)

I have dealt with delivery of my own patches over the years and came to the conclusion that the only reliable way of doing it, is to compile tehm into an application (not an mfx). Distributing the mfx means that you are relying on an MaxRuntime on that machine. But if the user installed a newer version, MacOS will try to redirect it to the newest installed version.
Would it be possible to distribute the next Orchids version as an app?

Best, Hans Tutschku

August 11, 2015 at 14:06 #14462
Profile photo of esling
esling

Dear Hans,

Yes in fact a major update is coming right before the next Forum event (in November) with bug settling, improved performance and a change in the search procedure to incorporate the duration of instruments in the temporal optimization. Thank you very much for your insight, we will indeed remove the mxf compilation made by the previous developer and replace it by an app.

All the best,
Philippe

August 12, 2015 at 17:03 #14471

You must be logged in to reply to this topic.

Log in now