Group Admins

  • Profile picture of bouchereau
  • Profile picture of daubresse
  • Profile picture of esling

Orchids

Public Group active 2 weeks, 3 days ago

Welcome to the Orchids user group.

This user group is devoted to the Orchids orchestration system and its users, but also on the topic of computer-aided orchestration and generic sound mixture optimization. In order to facilitate the exchange of bug reports, idea and collaborative thinking, we encourage any kind of report on errors, bad or good results, desired features, ideas, remarks and any other topic.

Please report any unsolved problem, ideas or even cool sounds to this group and we will be glad to discuss it. If you want to start using the software, please read the full documentation, which provides turnarounds to known issues: http://repmus.ircam.fr/_media/esling/orchids-documentation.pdf

http://forumnet.ircam.fr/user-groups/orchids/
http://forumnet.ircam.fr/product/orchids/

User folder

Author 2 Subscribed Users |
Profile photo of jbbollen
jbbollen

Dear Philippe,
My imported folder named ‘Car’ contains carillon soundfiles (mono 96 kHz, 16 bit) that follow the new Orchids 0.9.2 naming convention, for example: Car_normale-A#2-mf.aif. After parsed and build, the folder and its samples show up in the Explorer.
With everything in Queries deselected except my own imported ‘Car’ folder and the ‘user’ instruments/playing style, doing a query results in the message “No sample found”. The samples disappear from the Explorer and, consequently I can not access them anymore in the Inspector.
Orchids still orchestrates… but with SOL (only).
Could you advice me on how to get Orchids to recognise my soundfiles? Am I overlooking something?
Thanks in advance, Jan-Bas

May 25, 2016 at 14:20 #18107
Profile photo of jbbollen
jbbollen

Update:
I saw the naming of my samples was not quite right, I named them as follows: Car-A#2-mf.aif (since there is no particular playing style).
Now the samples are found but Orchids still orchestrates with SOL.
Also: how do I get rid of older versions of sources in the Queries?

May 28, 2016 at 09:54 #18138
Profile photo of jbbollen
jbbollen

New update:
My previous problem is partly solved: using the proper filtering, Orchids orchestrates with my own sounds.
However, there is no playback of the solutions possible. At first, I thought the sample-rate of 96 KHz might cause this, but this should not be the problem since both my source and target files use the same sample rate, which I also indicated in the Audio Setup.
And it still leaves me with the other issue of stray sources in the Queries… The latter is probably the result of the removal of an older folder with my sounds. I’ve been through the Orchids preferences file, but the older source can not be found there. Re-installing Orchids did not solve the problem…
As I’m in the middle of a project with these issues, any help would be much appreciated.
Jan-Bas

May 29, 2016 at 15:57 #18140
Profile photo of esling
esling

Dear Jbbollen,

I will try to synthesize your problem but right now it seems that you are able to add them correctly, they appear both in the explorer, queries and filters … and the algorithm is able to use these sounds to propose some solutions … but you are not able to hear these particular sounds when playing previews of the solutions ? I could tell you right away that I doubt the possibility of the 96kHz sample rate, as the analysis resample the rate automatically. Could you send me a few of these sounds so I can test them on my setup ?

Otherwise a few hints :
– Are you using sounds from an external drive ?
– Could you look at the file located here :
~/Library/Application\ Support/Orchids\ 0.9.2\ Preferences/Presets/orchids_folderpaths.txt
And post its content (while checking that the file indeed contain the correct path to your user sounds folder ?)
(I am guessing that it should most surely be a path issue)

The “stray sources” in the queries after removing an old folder is unfortunately a known bug … The only way to get rid of _everything_ is to delete the entire folder
~/Library/Application\ Support/Orchids\ 0.9.2\ Preferences/
However, this will of course also remove the user sounds that you added there

All the best,
Philippe

May 29, 2016 at 22:59 #18144
Profile photo of jbbollen
jbbollen

Thank you very much, Philippe.
I have been able to solve the above issue.
Although I did this just before your reply post came in and I can’t recall the exact steps of my actions, your assumption of it being a path issue turned out to be right: I do know that I cleaned up the path structure and now everything works fine, the orchids_folderpaths.txt shows the correct paths. And yes, my own samples are on an external SSD.
The preferences bug is uncomfortable to work with, since I had to trash the pref file several times over the last couple of days and re-analysing my own samples is quite a waste of time. But at least it works.
As I stated before, I work with 96 KHz samples and have set the according sample rate in the audio setup. The one major issue I still encounter is that “Set Current Solution As Target” renders a source at 44.1 KHz so it sounds an octave lower. I have the impression that Orchids fails to resample it after the analysis?
Thanks very much for your help with this otherwise fantastic software.
Jan-Bas

May 31, 2016 at 10:12 #18155
Profile photo of esling
esling

Cool to know that the problem is settled and that it was indeed from the folderpaths … I am also glad that using external drives as sources for the database is working as we never really tried that ! I agree that the preferences bug is quite awkward, the problem comes from the database handling system which is quite a hassle to juggle between core sounds and user sounds, we will work on fixing that in a next release.

In the meantime, you can perform backups of the whole “Orchids 0.9.2 Preferences” folder if you are in a “stable & working” state. That way, if something back happens, you can always switch back to this folder and everything should be working :)

Regarding your last comment, I think it is just an issue of the “interface vs. analysis” rendering. I am guessing that the interface might fail to resample correctly but the analysis should be handling it neatly. Could you confirm by listening to the “partials only rendering” (ie. slider on the bottom right of the partial analysis window) and tell me if the partials are also an octave lower or if it is just the wavefile rendering ?

May 31, 2016 at 10:54 #18158

You must be logged in to reply to this topic.

Log in now