Group Admins

  • Profile picture of warusfel
  • Profile picture of T.

Spat

Public Group active 17 hours, 33 minutes ago

User group for Spat, panoramix and ToscA

HRTF Selection issue

Author 3 Subscribed Users |
Profile photo of Sherk SCOTT
Sherk SCOTT

I recently upgraded to Max 6.1. Since I have done this I am having a problem with the abstraction spat.hrtf.selection.maxpat which is used in the help example for spat.virtualspeakers. When I select one of the coll files or hrtf files in the umenu I get a message that they cannot be found. I have placed the folder containing SPAT in my Max search path, but am still having this issue. Any help would be appreciated.
Thanks.

December 15, 2013 at 22:19 #7234
Profile photo of T.
T.

Hi Scott,

Could you please indicate what is the exact error message ?
Also what is your current sampling rate ? (most the hrtf files are only available for 44.1 kHz)

What happens if you send e.g. the following messages to spat.virtualspeakers~ :
[ load IRC_1004_itd_12order_biquads_44100.hrtf ]
[ load “/Applications/Max 6.1/packages/ircam-spat/media/hrtf/binaural/biquads/IRC_1004_itd_12order_biquads_44100.hrtf” ]
[ load “/Users/shrek/somewhere/IRC_1004_itd_12order_biquads_44100.hrtf” ]

(the first message searches for the file within your Max search path; with the other messages, you should specify the full path to the file somewhere on your disk).

December 16, 2013 at 11:44 #7236
Profile photo of Sherk SCOTT
Sherk SCOTT

Thank you for your reply. When using the abstraction spat.hrtf.selection.maxpat I get the following message:
Couldnt locate file ; 2-b1018-48000.coll

Using your first option– giving the message load {name of coll file or hrtf file} I am successful in loading. It seems that the abstraction may be mis-configured in some way.

December 17, 2013 at 16:00 #7258
Profile photo of T.
T.

OK. I Think there is no problem with the abstraction.
However, your Max/MSP seems to be running at 48000 Hz sampling rate.

As previously mentioned, most of the HRTF files are only available at 44100 Hz.
For instance, the Spat packages contains a ‘2b-1018-44100.coll’ file but no ‘2b-1018-48000.coll’.
So it makes sense that the file cannot be found.

If you really need to run at 48 kHz, you can have a look at the folder ‘ircam-spat/media/hrtf/transpan/binaural’ which contains a few files for this sampling rate.
(The naming convention used for these files is however slightly different, so you cannot use the spat.hrtf.selection abstraction to load them. You would have to build your own abstraction for that. I can help if needed).

December 17, 2013 at 16:11 #7259
Profile photo of Sherk SCOTT
Sherk SCOTT

Thank you! You correctly identified my problem. I had checked that the audio files that I was opening were 44.1, but I had not checked to see if Max was running in 44.1. Max was set at sampling rate of 4800! When re-set to 44.1 the .coll files load seamlessly. Thanks for the help.
Scott

December 17, 2013 at 21:55 #7260
Profile photo of raulquilez
raulquilez

I’m working at 96KHz, what solution would the use of hrtfs abstraction?
If I load directly binaural files to spat.spat ~ (@panning binaural @decoding null) using the “load” message (eg.:”load filename.hrtf” ) that’s work, even if at 96KHz, but if I load directly transaural files to spat.spat ~(@panningbinaural @transauraldecoding) does not work.

Thanks
Best
Raúl

October 2, 2015 at 20:45 #15027
Profile photo of T.
T.

Hi Raul,

Several things:

– at the moment, hrtf files are mostly provided for 44.1 or 48 kHz. Not for 96 kHz.
I recommend to use the proper filters corresponding to the used sampling rate,
although loading filters with a different sampling rate does not throw an error.

– we will soon work on 96 kHz filters and they will be provided in future releases.

– spat supports different transaural algorithms. Each algorithm requires a specific set of filters.
The files currently shipped in /ircam-spat/media/hrtf/transaural/biquads correspond to the so-called “shuffler symmetric” implementation.
The files currently shipped in /ircam-spat/media/hrtf/transaural/fir correspond to the so-called “feedforward asymmetric” implementation.
I know, this is not really logical, but we’ll definitely clarify this in further releases.

– Attached is a patch that demonstrates how to load the different kind of filters.

Hope this helps,
T.

— Pasted Max Patch, click to expand. —
October 2, 2015 at 21:56 #15030
Profile photo of raulquilez
raulquilez

Thank you so much for your answer T.

Everything is very clear.
We wait for future versions.
I know it’s not ideal to work with a different sampling frequency that the IR files (do not know how the system reacts, resampling…), but using that x2 sample rate of hrtf file, the artifacts are minimized (44.1 hrtf file— Sampling rate 88.2 kHz or 48.0 hrtf file— Sampling rate Khz 96). I have to test the possible occurrence of aliasing.

Thank you for your patch, and for your explanation about transaural setting filters.

Best
Raúl

October 3, 2015 at 11:39 #15031

You must be logged in to reply to this topic.

Log in now