Group Admins

  • Profile picture of warusfel
  • Profile picture of T.

Spat

Public Group active 1 day ago

User group for Spat, panoramix and ToscA

Problem with spat.oper

Author 3 Subscribed Users |
Profile photo of fraction
fraction

Hi,

Maybe it is not a problem, just a mistake in my patch. I am not really highly skilled in max msp coding, so please forgive my innocence in advance 😉

Here is my pb:

I am setting up some controls for spat.oper. I don’t understand why controlling Azimuth value sends value to Distance in the same time. I ve made a very simple patch to show my pb. Just play with the sliders. The Azimuth slider resets distance value permanently. The other slider doesn’t affect anything else. Could it be a coding bug? I looked into objects attributes/messages and didn’t find the solution. Thanks in advance for the help. Patch bellow.
Eric

{
“patcher” : {
“fileversion” : 1,
“appversion” : {
“major” : 6,
“minor” : 1,
“revision” : 5,
“architecture” : “x86″
}
,
“rect” : [ 240.0, 128.0, 1122.0, 810.0 ],
“bglocked” : 0,
“openinpresentation” : 0,
“default_fontsize” : 12.0,
“default_fontface” : 0,
“default_fontname” : “Arial”,
“gridonopen” : 0,
“gridsize” : [ 15.0, 15.0 ],
“gridsnaponopen” : 0,
“statusbarvisible” : 2,
“toolbarvisible” : 1,
“boxanimatetime” : 200,
“imprint” : 0,
“enablehscroll” : 1,
“enablevscroll” : 1,
“devicewidth” : 0.0,
“description” : “”,
“digest” : “”,
“tags” : “”,
“boxes” : [ {
“box” : {
“fontname” : “Arial”,
“fontsize” : 12.0,
“id” : “obj-6″,
“maxclass” : “newobj”,
“numinlets” : 6,
“numoutlets” : 1,
“outlettype” : [ “” ],
“patching_rect” : [ 438.0, 229.0, 105.0, 20.0 ],
“text” : “scale 0. 127. 0. 1.”
}

}
, {
“box” : {
“id” : “obj-5″,
“maxclass” : “slider”,
“numinlets” : 1,
“numoutlets” : 1,
“outlettype” : [ “” ],
“parameter_enable” : 0,
“patching_rect” : [ 438.0, 54.0, 20.0, 140.0 ],
“relative” : 1
}

}
, {
“box” : {
“fontname” : “Arial”,
“fontsize” : 12.0,
“id” : “obj-4″,
“maxclass” : “newobj”,
“numinlets” : 1,
“numoutlets” : 1,
“outlettype” : [ “” ],
“patching_rect” : [ 438.0, 276.0, 126.0, 20.0 ],
“text” : “prepend source 1 dist”
}

}
, {
“box” : {
“id” : “obj-3″,
“maxclass” : “slider”,
“numinlets” : 1,
“numoutlets” : 1,
“outlettype” : [ “” ],
“parameter_enable” : 0,
“patching_rect” : [ 296.0, 74.0, 20.0, 140.0 ],
“relative” : 1
}

}
, {
“box” : {
“fontname” : “Arial”,
“fontsize” : 12.0,
“id” : “obj-2″,
“maxclass” : “newobj”,
“numinlets” : 1,
“numoutlets” : 1,
“outlettype” : [ “” ],
“patching_rect” : [ 296.0, 276.0, 120.0, 20.0 ],
“text” : “prepend source 1 az”
}

}
, {
“box” : {
“fontname” : “Arial”,
“fontsize” : 12.0,
“id” : “obj-1″,
“maxclass” : “newobj”,
“numinlets” : 1,
“numoutlets” : 3,
“outlettype” : [ “”, “”, “” ],
“patching_rect” : [ 296.0, 466.0, 249.0, 20.0 ],
“saved_object_attributes” : {
“parameter_enable” : 0
}
,
“text” : “spat.oper @numsources 1 @numspeakers 5″
}

}
],
“lines” : [ {
“patchline” : {
“destination” : [ “obj-1″, 0 ],
“disabled” : 0,
“hidden” : 0,
“source” : [ “obj-2″, 0 ]
}

}
, {
“patchline” : {
“destination” : [ “obj-2″, 0 ],
“disabled” : 0,
“hidden” : 0,
“midpoints” : [ 305.5, 242.0, 305.5, 242.0 ],
“source” : [ “obj-3″, 0 ]
}

}
, {
“patchline” : {
“destination” : [ “obj-1″, 0 ],
“disabled” : 0,
“hidden” : 0,
“midpoints” : [ 447.5, 452.0, 305.5, 452.0 ],
“source” : [ “obj-4″, 0 ]
}

}
, {
“patchline” : {
“destination” : [ “obj-6″, 0 ],
“disabled” : 0,
“hidden” : 0,
“source” : [ “obj-5″, 0 ]
}

}
, {
“patchline” : {
“destination” : [ “obj-4″, 0 ],
“disabled” : 0,
“hidden” : 0,
“source” : [ “obj-6″, 0 ]
}

}
],
“dependency_cache” : [ {
“name” : “spat.oper.mxo”,
“type” : “iLaX”
}
]
}

}

August 28, 2014 at 11:02 #10319
Profile photo of T.
T.

Hi,

You should use the “azim” message instead.

Have a look at the attached patch.

T.

— Pasted Max Patch, click to expand. —
August 28, 2014 at 11:08 #10320
Profile photo of fraction
fraction

see, my innocence. I guess i still have a long way to learn the entire spat message glossary 😉

Thanks for the help T. !
Eric

August 28, 2014 at 11:20 #10321
Profile photo of ShingKweiTzeng
ShingKweiTzeng

Hello! Fraction.
your patch seems valuable for me, how can I copy and open from text in MSP 6? there is no more ” Open from clipboard” (Max 5), I have ” Open from text” and replace the content then save as a new emptypatch.pat, still can’t open.
thanks!

Shing-kwei

December 14, 2015 at 12:49 #16488
Profile photo of ShingKweiTzeng
ShingKweiTzeng

Hello! Fraction.
your patch seems valuable for me, how can I copy and open from text in MSP 6? there is no more ” Open from clipboard” (Max 5), I have ” Open from text” and replace the content then save as a new emptypatch.pat, still can’t open.
thanks!

Shing-kwei

December 14, 2015 at 12:49 #16487
Profile photo of ShingKweiTzeng
ShingKweiTzeng

hello! I found “New from clipboard”.

SK.

December 14, 2015 at 15:51 #16489

You must be logged in to reply to this topic.

Log in now