Group Admins

  • Profile picture of warusfel
  • Profile picture of T.

Spat

Public Group active 1 week, 1 day ago

User group for Spat, panoramix, ToscA , and ADMix

ToscA Reaper Spat

Author 3 Subscribed Users |
Profile photo of Sherk SCOTT
Sherk SCOTT

I have successfully used ToscA with Ableton Live 10 to write automation for Spat, and to record automation in Live when moving sources in Spat. I have been unsuccessful in recording automation when using Reaper. I selected “process all notifications” in preferences, as indicated in manual. Additionally output port shows red, although Spat Viewer responds to Reaper written automation. I searched through the forum but can’t find any know issues with Reaper. Using Reaper 5.91/64. I have been using tosca-basic-examples.maxpat. Probably missing something simple… Thanks for any help.

September 8, 2018 at 02:33 #27706
Profile photo of HEM de Genève
HEM de Genève

Hey,
I just checked with my Reaper (5.94/64) and Panoramix (Spat 5 in the box) and it works even after holidays.
If it works well with Ableton, I assume the problem is from reaper only.
You put Tosca with the good mapping file. In the envelope for track window you put for exemple “write” in Automation mode so the square turned red. The you ticked the parameters you want to see (x, y, z, or dist, azim or whatever) and finally you clic on the grey button with the green circle on each parameter track (if think it’s already done) and it turned more green and the knob just under turn red.

At this point, if I press space bar it works.
Tell me if you made all this steps and it doesn’t work.

Christophe

September 8, 2018 at 10:51 #27707
Profile photo of Sherk SCOTT
Sherk SCOTT

Thanks, Christophe. Yes I have been following those steps. When in “write” Reaper does not seem to receive OSC messages.

September 8, 2018 at 14:27 #27708
Profile photo of HEM de Genève
HEM de Genève

And when you move something in spat, does the input port blink in yellow in the tosca plugin window in reaper ?

September 8, 2018 at 17:09 #27709
Profile photo of T.
T.

Hi Scott,
The port number being displayed in red is not a good sign (the port cannot be bound — for whatever reason, e.g. another application already using it).
Try using a different port.
T.

September 9, 2018 at 11:15 #27710
Profile photo of Sherk SCOTT
Sherk SCOTT

Of course! Changing the input port to anything but the default 4001 allows it to be bound and removes the red from the output port. Now it works like a charm. Interestingly this is not an issue with Live.
Thanks for the help T. and Christophe!

September 9, 2018 at 20:44 #27727

You must be logged in to reply to this topic.

Log in now